Black screen after "Loading Portal" on some Portals

Smart STB gets black (white/grey) screen after "Loading Portal"?

Sometimes you may get white screen, grey screen, etc.

(Depending on the TV and OS)

 

Possible reasons:
  • Sometimes Portal redirect will cause this due to limitations of some Smart TV platforms. We recommend putting in the direct URL to the Portal. 

    Correct Portal URL are like 
    http://some-provider.tld/stalker_portal/c/index.html 
    http://box.some-provider.tld/c/index.html 

    Wrong Portal URL looks like 
    http://box.some-provider.tld/
    http://stb.some-provider.tld/
    http://mag.box.some-provider.tld/

    that redirects to 
    http://some-provider.tld/stalker_portal/c/index.html 

  • If you are using other emulator like STBEmu to access the same Portal with the same Virtual MAC address then it's most likely that Provider has detected a conflict (a cloned device) and will block access or lock it only to the first device that logged in.
    Solution: ask your Provider to DELETE your account from the Portal. Not Disable, but completely DELETE it. Along with the Virtual MAC address. After that ask them to RECREATE your account. And make sure you login ONLY with Smart STB. If you want to use the Portals with other apps at the same time make sure you have a separate account for this. Going into the Portal from many devices with same Virtual MAC will cause problems!
  • Another common reason is wrong time and date setting on TV or wrong Clock source setting inside the app.
    Please go to app's setting by pressing OK/Center key as soon as you see Loading Portal, then go to System Settings > Advanced settings and change Clock Source to Auto (Default) like shown below.

    Make sure your TV's time/clock and timezone settings are correct and you get the correct time and date on your TV.
  • Other reason for this could be that Portal maybe having technical difficulties. Example: server is overloaded, database is broken, etc.
  • Finally make sure your Portal URL is correct. Sometimes incorrect Portal URL can result in black screen on TV because app is expecting a Portal but got an unexpected server response due to the wrong URL. Check above to see how correct Portal URL looks like.

 

 

In case nothing of the above did not helped you, please open a ticket so we can check the issue with your Portal further.
Please do check if the Demo (Embedded) Portal loads fine on your TV before opening a ticket.

  • 8 Users Found This Useful
Was this answer helpful?

Related Articles

Your STB is blocked - call the Provider. Now what?

If you get message like: Your STB is blocked.Call the provider. This means that your device...

Error accessing portal message

Error accessing portal message is displayed like shown below. If you get this error it's most...

App gets stuck on Loading Portal screen

Stuck on Loading portal... screen? There are many reasons for this to happen. Most popular...

Firmware of your STB is outdated Please update it

Firmware of your STB is outdated Please update it There are few reasons for this to happen:...

App is not playing any live TV or Video - only black screen is displayed.

  In case your Portal loads, you see all the live channels (or Videos, if in Videoclub) or...